1 (8 лет 10 месяцев назад)

Тема: маленькая помощь в экселе

нужно формулу:

ячейка А1 пишешь число
ячейка А2 считает и выдает большее из чисел из условий( А1+10% от А1, +100 к А1)

напишите формулу в А2, заранее спасибо!  smile

Тема закрыта и находится в архиве, не беспокойте автора без особой необходимости!

2 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

сформулируй нормально задачу

3 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

надо постоянно выполнять 2 эти действия и сравнивать их разность с нулем(все в одной формуле). лень писать счас формулу. если утром напомнишь - сделаю.

4 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

ну я думаю до завтра дотерплю ))

Сам осилить не могу эту сложную программу  big_smile

Тема закрыта и находится в архиве, не беспокойте автора без особой необходимости!

5 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

о_О

=ЕСЛИ(A1+A1*0,1>A1+100;A1+A1*0,1;A1+100)

Не думал, что такие "феноменальные" знания могут мне пригодиться)

Отредактировано (09.07.2012 23:10:42, 8 лет 10 месяцев назад)

6 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

-=KORSAR=- пишет:

о_О

=ЕСЛИ(A1+A1*0,1>A1+100;A1+A1*0,1;A1+100)

как-то так

7 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

ilyja,
Если я правильно понял, то в ячейку А2 должна быть формула:

=ЕСЛИ(A1*1,1>=A1+100;A1*1,1;A1+100)

8 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

Athlon82, да не как-то, а точно так)

Ну или так, для красоты:

=ЕСЛИ(A1*1,1>A1+100;A1*1,1;A1+100)

9 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

-=KORSAR=- пишет:

Athlon82, да не как-то, а точно так)

Ну или так, для красоты:

=ЕСЛИ(A1*1,1>A1+100;A1*1,1;A1+100)

это не для красоты, а для краткости big_smile

10 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

Athlon82 пишет:
-=KORSAR=- пишет:

Athlon82, да не как-то, а точно так)

Ну или так, для красоты:

=ЕСЛИ(A1*1,1>A1+100;A1*1,1;A1+100)

это не для красоты, а для краткости big_smile

для красоты и как миниму на одно действие меньше smile
если оптимизатор работает хорошо:)
хотя какой нафиг оптимизатор там smile то тогда на два

11 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

Алгоритмическая красота в краткости)

Вот еще вариант xD Процу так по-проще)

=ЕСЛИ(A1*0,1-100>0;A1*1,1;A1+100)

12 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

Зло пишет:
Athlon82 пишет:
-=KORSAR=- пишет:

Athlon82, да не как-то, а точно так)

Ну или так, для красоты:

=ЕСЛИ(A1*1,1>A1+100;A1*1,1;A1+100)

это не для красоты, а для краткости big_smile

для красоты и как миниму на одно действие меньше smile
если оптимизатор работает хорошо:)
хотя какой нафиг оптимизатор там smile то тогда на два

+наглядность хуже

13 (8 лет 10 месяцев назад)

Re: маленькая помощь в экселе

-=KORSAR=- пишет:

Алгоритмическая красота в краткости)

Вот еще вариант xD Процу так по-проще)

=ЕСЛИ(A1*0,1-100>0;A1*1,1;A1+100)

Ай да молодца!

Спасибо!

Тема закрыта и находится в архиве, не беспокойте автора без особой необходимости!